linux poison RSS
linux poison Email

Multimedia support in OpenSuse 11.1 (MP3, MPEG-4, DiVX, etc.)

Why doesn’t OpenSuSe support MP3 ‘out of the box’?
OpenSuSe cannot include support for MP3 or DVD video playback or recording. MP3 formats are patented, and the patent holders have not provided the necessary licenses. OpenSuSe also excludes other multimedia software due to patent, copyright, or license restrictions, such as Adobe Flash Player and RealNetworks RealPlayer.
That doesn’t mean you can’t play .mp3 files in OpenSuSe , it just takes a bit of work (not much).

Follow these instructions to get mp3 and other multimedia support on your OpenSuSe 11.1.

If you are using KDE - Download and run (execute) this
If you are using Gnome - Download and execute this

Want VLC player - Download and run this

This will enable you to have:
Flash
Java
Latest Amarok (with MP3 Support) for KDE, or Helix-Banshee for GNOME users
Encrypted DVD (libdvdcss)
Extra XINE Codecs, for DivX/Xvid etc. (libxine1)
K3b with MP3 Support (k3b-codecs)
Win 32 Codecs (w32codec-all)

And after sucesfull installation you should be able to play any media files.




12 comments:

Steve Goodey said...

Sorry, but this doesn't work, neither kaffeine or VLC will play a non-encrypted DVD, both say the source can't be read, although opensuse was installed from the same dvd drive.

Steve Goodey said...

Hello,
Left a rather terse comment the other day about your Multimedia support in OpenSuse 11.1 article not working. Sorry about that, permissions problem on the dvd drive wrong, known bug, once again sorry.

Steve.

Anonymous said...

Works fine on OpenSuse 11.1 KDE4.
Thank you!

Anonymous said...

Works like a charm , thanks a lot !
openSusE 11.1 KDE4 .

Ramanath said...

The article helped a lot. Everything worked as a charm . Thanks buddy !!!

MAD~FUZE said...

cool cool needing that! cheers dude!

Anonymous said...

work fine with Amarok ... you mlust change engine to XINE. enjoy your mp3 ...

Anonymous said...

I decided to use yast to install libxine1-codecs. With yast handling the dependencies, I was able to get amarok to play mp3s. I then added the other codecs mentioned in the install list as well. Altho-I did not use the installer program here, I have no doubt it will work on my system (11.1 x64).

PE said...

Thank you, very much! Its work!!!

Anonymous said...

too good...

Anonymous said...

So easy... Simply a perfekt peace of work!!!

Anonymous said...

help please does it need internet connection to install? when i try it shows package not installed successfully

Post a Comment

Related Posts with Thumbnails